Upskew Pty. Ltd.

Menu

What device do I need to run Knowin?

Knowin supports most iPhone and iPad devices, running iOS 8.0 and above.

If you're using Android, you might like Encode for Android.